CVE-2019-12471: MediaWiki Cross-site Scripting (XSS)
(updated )
Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
References
- github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2019-12471.yaml
- github.com/advisories/GHSA-2rm7-xxx8-35jh
- github.com/wikimedia/mediawiki
- lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html
- nvd.nist.gov/vuln/detail/CVE-2019-12471
- phabricator.wikimedia.org/T207603
- seclists.org/bugtraq/2019/Jun/12
- www.debian.org/security/2019/dsa-4460
Code Behaviors & Features
Detect and mitigate CVE-2019-12471 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →