Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. mediawiki/core
  4. ›
  5. CVE-2014-2853

CVE-2014-2853: Cross-site scripting vulnerability in includes/actions/InfoAction.php

May 17, 2022 (updated November 1, 2024)

Cross-site scripting (XSS) vulnerability in includes/actions/InfoAction.php in MediaWiki before 1.21.9 and 1.22.x before 1.22.6 allows remote attackers to inject arbitrary web script or HTML via the sort key in an info action.

References

  • bugzilla.redhat.com/show_bug.cgi?id=1091967
  • bugzilla.wikimedia.org/show_bug.cgi?id=63251
  • github.com/advisories/GHSA-6h86-9r5g-f2h5
  • github.com/wikimedia/mediawiki
  • github.com/wikimedia/mediawiki-core/commit/0b695ae09aada343ab59be4a3c9963995a1143b6
  • nvd.nist.gov/vuln/detail/CVE-2014-2853
  • www.mediawiki.org/wiki/Release_notes/1.21
  • www.mediawiki.org/wiki/Release_notes/1.22

Code Behaviors & Features

Detect and mitigate CVE-2014-2853 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.21.9, all versions starting from 1.22.0 before 1.22.6

Fixed versions

  • 1.21.9
  • 1.22.6

Solution

Upgrade to versions 1.21.9, 1.22.6 or above.

Impact 4.3 MEDIUM

AV:N/AC:M/Au:N/C:N/I:P/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/mediawiki/core/CVE-2014-2853.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:47 +0000.