Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. mautic/core
  4. ›
  5. CVE-2025-13828

CVE-2025-13828: Mautic user without privileged access to the Marketplace can install and uninstall composer packages

December 2, 2025

A non privileged user can install and remove arbitrary packages via composer for a composer based installed, even if the flag in update settings for enable composer based update is unticked.

References

  • github.com/advisories/GHSA-3fq7-c5m8-g86x
  • github.com/mautic/mautic
  • github.com/mautic/mautic/security/advisories/GHSA-3fq7-c5m8-g86x
  • nvd.nist.gov/vuln/detail/CVE-2025-13828

Code Behaviors & Features

Detect and mitigate CVE-2025-13828 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.0.0 before 4.4.18, all versions starting from 5.0.0 before 5.2.9, all versions starting from 6.0.0 before 6.0.7

Fixed versions

  • 4.4.18
  • 5.2.9
  • 6.0.7

Solution

Upgrade to versions 4.4.18, 5.2.9, 6.0.7 or above.

Impact 9.9 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-284: Improper Access Control
  • CWE-862: Missing Authorization

Source file

packagist/mautic/core/CVE-2025-13828.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:27 +0000.