Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. mautic/core
  4. ›
  5. CVE-2021-27914

CVE-2021-27914: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

June 1, 2022 (updated June 8, 2022)

A cross-site scripting (XSS) vulnerability in the installer component of Mautic before 4.3.0 allows admins to inject executable javascript

References

  • github.com/mautic/mautic/security/advisories/GHSA-jrwm-pr9x-cgq3
  • nvd.nist.gov/vuln/detail/CVE-2021-27914

Code Behaviors & Features

Detect and mitigate CVE-2021-27914 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.3.0

Fixed versions

  • 4.3.0

Solution

Upgrade to version 4.3.0 or above.

Impact 4.8 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/mautic/core/CVE-2021-27914.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:30 +0000.