Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. mautic/core
  4. ›
  5. CVE-2021-27909

CVE-2021-27909: Cross-site Scripting

August 30, 2021 (updated September 10, 2021)

There is an XSS vulnerability on Mautic’s password reset page where a vulnerable parameter bundle in the URL could allow an attacker to execute Javascript code. The attacker would be required to convince or trick the target into clicking a password reset URL with the vulnerable parameter utilized.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-27909

Code Behaviors & Features

Detect and mitigate CVE-2021-27909 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.3.4, all versions starting from 4.0.0-alpha1 before versions before 4.0.0

Fixed versions

  • 3.3.4
  • 4.0.0

Solution

Upgrade to version 3.3.4, 4.0.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Source file

packagist/mautic/core/CVE-2021-27909.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:27 +0000.