Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. mautic/core
  4. ›
  5. CVE-2017-1000506

CVE-2017-1000506: Cross-site Scripting

February 9, 2018 (updated February 26, 2018)

Mautic contains a Cross Site Scripting (XSS) vulnerability in Company’s name that can result in denial of service and execution of javascript code.

References

  • github.com/mautic/mautic/issues/5222
  • nvd.nist.gov/vuln/detail/CVE-2017-1000506

Code Behaviors & Features

Detect and mitigate CVE-2017-1000506 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 2.11.0

Fixed versions

  • 2.12.0

Solution

Upgrade to version 2.12.0 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/mautic/core/CVE-2017-1000506.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:00 +0000.