Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/product-community-edition
  4. ›
  5. CVE-2019-8121

CVE-2019-8121: Using JS libraries with known security vulnerabilities

November 12, 2019 (updated February 5, 2024)

An insecure component vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. Magento 2 codebase leveraged outdated versions of JS libraries (Bootstrap, jquery, Knockout) with known security vulnerabilities.

References

  • github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8121.yaml
  • github.com/advisories/GHSA-89ch-hqf9-rgp3
  • magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
  • nvd.nist.gov/vuln/detail/CVE-2019-8121

Code Behaviors & Features

Detect and mitigate CVE-2019-8121 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.2 before 2.2.10, all versions starting from 2.3 before 2.3.2-p2

Fixed versions

  • 2.2.10
  • 2.3.2-p2

Solution

Upgrade to versions 2.2.10, 2.3.2-p2 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

packagist/magento/product-community-edition/CVE-2019-8121.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:01 +0000.