Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/core
  4. ›
  5. CVE-2020-9591

CVE-2020-9591: Magento defense-in-depth security mitigation vulnerability

May 24, 2022 (updated January 11, 2024)

Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a defense-in-depth security mitigation vulnerability. Successful exploitation could lead to unauthorized access to admin panel.

References

  • github.com/advisories/GHSA-w7rh-9w5v-rwqj
  • helpx.adobe.com/security/products/magento/apsb20-22.html
  • nvd.nist.gov/vuln/detail/CVE-2020-9591

Code Behaviors & Features

Detect and mitigate CVE-2020-9591 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.9.4.5

Fixed versions

  • 1.9.4.5

Solution

Upgrade to version 1.9.4.5 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Source file

packagist/magento/core/CVE-2020-9591.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:29 +0000.