Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. GHSA-8j7c-682x-r9f2

GHSA-8j7c-682x-r9f2: Magento RCE,XSS and other vulnerabilities

May 15, 2024

Magento Commerce and Open Source 2.3.0, 2.2.7 and 2.1.16 contain multiple security enhancements that help close Remote Code Execution (RCE), Cross-Site Scripting (XSS) and other vulnerabilities.

References

  • github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/2018-11-28.yaml
  • github.com/advisories/GHSA-8j7c-682x-r9f2
  • github.com/magento/magento2
  • web.archive.org/web/20210802095950/https://magento.com/security/patches/magento-2.2.7-and-2.1.16-security-update

Code Behaviors & Features

Detect and mitigate GHSA-8j7c-682x-r9f2 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.1 before 2.1.16, all versions starting from 2.2 before 2.2.7

Fixed versions

  • 2.1.16
  • 2.2.7

Solution

Upgrade to versions 2.1.16, 2.2.7 or above.

Source file

packagist/magento/community-edition/GHSA-8j7c-682x-r9f2.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:30 +0000.