Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2025-49549

CVE-2025-49549: Magento Authenticated Security feature bypass

June 26, 2025 (updated October 22, 2025)

Magento versions 2.4.8, 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13 and earlier are affected by an Incorrect Authorization vulnerability that could result in a Security feature bypass. A high-privileged attacker could leverage this vulnerability to bypass security measures and gain limited unauthorized access. Exploitation of this issue does not require user interaction.

References

  • github.com/advisories/GHSA-85jx-x9r4-45m2
  • github.com/magento/magento2
  • helpx.adobe.com/security/products/magento/apsb25-50.html
  • nvd.nist.gov/vuln/detail/CVE-2025-49549

Code Behaviors & Features

Detect and mitigate CVE-2025-49549 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.4.5-p13, version 2.4.5, all versions starting from 2.4.6-p1 before 2.4.6-p11, version 2.4.6, all versions starting from 2.4.7-beta1 before 2.4.7-p6, version 2.4.7, version 2.4.8

Fixed versions

  • 2.4.7-p6
  • 2.4.6-p11
  • 2.4.5-p13

Solution

Upgrade to versions 2.4.5-p13, 2.4.6-p11, 2.4.7-p6 or above.

Impact 2.7 LOW

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

packagist/magento/community-edition/CVE-2025-49549.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:20 +0000.