Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2025-24437

CVE-2025-24437: Magento Improper Access Control vulnerability

February 11, 2025 (updated February 28, 2025)

Adobe Commerce versions 2.4.7-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Improper Access Control vulnerability that could result in privilege escalation. A low-privileged attacker could leverage this vulnerability to bypass security measures and gain elevated privileges. Exploitation of this issue does not require user interaction.

References

  • github.com/advisories/GHSA-469f-wf4f-3jjv
  • github.com/magento/magento2
  • helpx.adobe.com/security/products/magento/apsb25-08.html
  • nvd.nist.gov/vuln/detail/CVE-2025-24437

Code Behaviors & Features

Detect and mitigate CVE-2025-24437 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.4.4-p12, version 2.4.4, all versions starting from 2.4.5-p1 before 2.4.5-p11, version 2.4.5, all versions starting from 2.4.6-p1 before 2.4.6-p9, version 2.4.6, all versions starting from 2.4.7-beta1 before 2.4.7-p4, version 2.4.7, version 2.4.8-beta1

Fixed versions

  • 2.4.7-p4
  • 2.4.6-p9
  • 2.4.5-p11
  • 2.4.4-p12

Solution

Upgrade to versions 2.4.4-p12, 2.4.5-p11, 2.4.6-p9, 2.4.7-p4 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-284: Improper Access Control

Source file

packagist/magento/community-edition/CVE-2025-24437.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:20 +0000.