Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2024-45135

CVE-2024-45135: Magento Open Source Improper Access Control vulnerability

October 10, 2024 (updated October 11, 2024)

Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An admin attacker could leverage this vulnerability to bypass security measures and have a low impact on integrity. Exploitation of this issue does not require user interaction.

References

  • github.com/advisories/GHSA-8pxg-gcp4-57ww
  • github.com/magento/magento2
  • helpx.adobe.com/security/products/magento/apsb24-73.html
  • nvd.nist.gov/vuln/detail/CVE-2024-45135

Code Behaviors & Features

Detect and mitigate CVE-2024-45135 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.4.4-p11, version 2.4.4, all versions starting from 2.4.5-p1 before 2.4.5-p10, version 2.4.5, all versions starting from 2.4.6-p1 before 2.4.6-p8, version 2.4.6, all versions starting from 2.4.7-beta1 before 2.4.7-p3, version 2.4.7

Fixed versions

  • 2.4.7-p3
  • 2.4.6-p8
  • 2.4.5-p10
  • 2.4.4-p11

Solution

Upgrade to versions 2.4.4-p11, 2.4.5-p10, 2.4.6-p8, 2.4.7-p3 or above.

Impact 2.7 LOW

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-284: Improper Access Control

Source file

packagist/magento/community-edition/CVE-2024-45135.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:17 +0000.