Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2024-45125

CVE-2024-45125: Magento Open Source Incorrect Authorization vulnerability

October 10, 2024 (updated October 11, 2024)

Magento Open Source versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could exploit this vulnerability to have a low impact on integrity. Exploitation of this issue does not require user interaction.

References

  • github.com/advisories/GHSA-xg36-8c2v-jpxh
  • github.com/magento/magento2
  • helpx.adobe.com/security/products/magento/apsb24-73.html
  • nvd.nist.gov/vuln/detail/CVE-2024-45125

Code Behaviors & Features

Detect and mitigate CVE-2024-45125 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.4.4-p11, version 2.4.4, all versions starting from 2.4.5-p1 before 2.4.5-p10, version 2.4.5, all versions starting from 2.4.6-p1 before 2.4.6-p8, version 2.4.6, all versions starting from 2.4.7-beta1 before 2.4.7-p3, version 2.4.7

Fixed versions

  • 2.4.7-p3
  • 2.4.6-p8
  • 2.4.5-p10
  • 2.4.4-p11

Solution

Upgrade to versions 2.4.4-p11, 2.4.5-p10, 2.4.6-p8, 2.4.7-p3 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

packagist/magento/community-edition/CVE-2024-45125.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:27 +0000.