Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2024-39412

CVE-2024-39412: Magento Open Source Improper Authorization vulnerability

August 14, 2024 (updated September 16, 2024)

Magento Open Source versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Authorization vulnerability that could result in a Security feature bypass. A low-privileged attacker could leverage this vulnerability to bypass security measures and disclose minor information. Exploitation of this issue does not require user interaction.

References

  • github.com/advisories/GHSA-7472-vw39-g2j3
  • github.com/magento/magento2
  • helpx.adobe.com/security/products/magento/apsb24-61.html
  • nvd.nist.gov/vuln/detail/CVE-2024-39412

Code Behaviors & Features

Detect and mitigate CVE-2024-39412 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.4.4-p10, version 2.4.4, all versions starting from 2.4.5-p1 before 2.4.5-p9, version 2.4.5, all versions starting from 2.4.6-p1 before 2.4.6-p7, version 2.4.6, all versions starting from 2.4.7-p1 before 2.4.7-p2, version 2.4.7

Fixed versions

  • 2.4.7-p2
  • 2.4.6-p7
  • 2.4.5-p9
  • 2.4.4-p10

Solution

Upgrade to versions 2.4.4-p10, 2.4.5-p9, 2.4.6-p7, 2.4.7-p2 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-285: Improper Authorization

Source file

packagist/magento/community-edition/CVE-2024-39412.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:15 +0000.