Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2023-29297

CVE-2023-29297: Magento Open Source allows Improper Neutralization of Special Elements Used

June 15, 2023 (updated March 4, 2025)

Adobe Commerce versions 2.4.6 (and earlier), 2.4.5-p2 (and earlier) and 2.4.4-p3 (and earlier) are affected by a Improper Neutralization of Special Elements Used in a Template Engine vulnerability that could lead to arbitrary code execution by an admin-privilege authenticated attacker. Exploitation of this issue does not require user interaction.

References

  • github.com/advisories/GHSA-gfmm-ww6f-5mm5
  • github.com/magento/magento2
  • helpx.adobe.com/security/products/magento/apsb23-35.html
  • nvd.nist.gov/vuln/detail/CVE-2023-29297

Code Behaviors & Features

Detect and mitigate CVE-2023-29297 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.4.4-p1 before 2.4.4-p4, version 2.4.4, all versions starting from 2.4.5-p1 before 2.4.5-p3, version 2.4.5, version 2.4.6

Fixed versions

  • 2.4.5-p3
  • 2.4.4-p4

Solution

Upgrade to versions 2.4.4-p4, 2.4.5-p3 or above.

Impact 7.2 HIGH

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-1336: Improper Neutralization of Special Elements Used in a Template Engine

Source file

packagist/magento/community-edition/CVE-2023-29297.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:12 +0000.