Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2023-22251

CVE-2023-22251: Magento Open Source allows Incorrect Authorization

March 27, 2023 (updated March 4, 2025)

Adobe Commerce versions 2.4.4-p2 (and earlier) and 2.4.5-p1 (and earlier) are affected by an Incorrect Authorization vulnerability. A low-privileged authenticated attacker could leverage this vulnerability to achieve minor information disclosure.

References

  • github.com/advisories/GHSA-2wm7-mmgc-qxr3
  • github.com/magento/magento2
  • helpx.adobe.com/security/products/magento/apsb23-17.html
  • nvd.nist.gov/vuln/detail/CVE-2023-22251

Code Behaviors & Features

Detect and mitigate CVE-2023-22251 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.4.4-p1 before 2.4.4-p3, version 2.4.4, all versions starting from 2.4.5-p1 before 2.4.5-p2, version 2.4.5-p1, version 2.4.5

Fixed versions

  • 2.4.4-p3
  • 2.4.5-p2

Solution

Upgrade to versions 2.4.4-p3, 2.4.5-p2 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

packagist/magento/community-edition/CVE-2023-22251.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:31 +0000.