Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2022-42344

CVE-2022-42344: Improper Input Validation

October 20, 2022 (updated December 4, 2023)

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an improper input validation vulnerability. An authenticated attacker can trigger an insecure direct object reference in the V1/customers/me endpoint to achieve information exposure and privilege escalation.

References

  • helpx.adobe.com/security/products/magento/apsb22-38.html
  • nvd.nist.gov/vuln/detail/CVE-2022-42344

Code Behaviors & Features

Detect and mitigate CVE-2022-42344 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.7, all versions starting from 2.4.0 before 2.4.3

Fixed versions

  • 2.3.7
  • 2.4.3

Solution

Upgrade to versions 2.3.7, 2.4.3 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

packagist/magento/community-edition/CVE-2022-42344.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:25 +0000.