Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2022-35692

CVE-2022-35692: Magento Open Source has Improper Access Control vulnerability

August 20, 2022 (updated February 12, 2025)

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to leak minor information of another user’s account details. Exploitation of this issue does not require user interaction.

References

  • github.com/advisories/GHSA-gm4m-9rm8-7rxj
  • helpx.adobe.com/security/products/magento/apsb22-38.html
  • nvd.nist.gov/vuln/detail/CVE-2022-35692

Code Behaviors & Features

Detect and mitigate CVE-2022-35692 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.3.7-p1 before 2.3.7-p4, version 2.3.7, all versions starting from 2.4.3-p1 before 2.4.3-p3, version 2.4.3, version 2.4.4

Fixed versions

  • 2.4.3-p3
  • 2.3.7-p4

Solution

Upgrade to versions 2.3.7-p4, 2.4.3-p3 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

packagist/magento/community-edition/CVE-2022-35692.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:24 +0000.