Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2022-35689

CVE-2022-35689: Magento Open Source allows Improper Access Control

October 15, 2022 (updated March 4, 2025)

Adobe Commerce versions 2.4.3-p3 (and earlier), 2.4.4-p1 (and earlier) and 2.4.5 (and earlier) are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to impact the availability of a user’s minor feature. Exploitation of this issue does not require user interaction.

References

  • github.com/advisories/GHSA-5fxx-jwjm-x9hj
  • github.com/magento/magento2
  • helpx.adobe.com/security/products/magento/apsb22-48.html
  • nvd.nist.gov/vuln/detail/CVE-2022-35689

Code Behaviors & Features

Detect and mitigate CVE-2022-35689 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.4.3-p1 up to 2.4.3-p3, version 2.4.3, all versions starting from 2.4.4-p1 before 2.4.4-p2, version 2.4.4-p1, version 2.4.4, version 2.4.5

Fixed versions

  • 2.4.4-p2

Solution

Upgrade to version 2.4.4-p2 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Learn more about CVSS

Weakness

  • CWE-284: Improper Access Control

Source file

packagist/magento/community-edition/CVE-2022-35689.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:22 +0000.