Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2022-34259

CVE-2022-34259: Improper Access Control

August 16, 2022 (updated July 21, 2023)

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to impact the availability of a user’s minor feature. Exploitation of this issue does not require user interaction.

References

  • helpx.adobe.com/security/products/magento/apsb22-38.html
  • nvd.nist.gov/vuln/detail/CVE-2022-34259

Code Behaviors & Features

Detect and mitigate CVE-2022-34259 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.3.0 before 2.3.7, all versions starting from 2.4.0 before 2.4.4

Fixed versions

  • 2.3.7
  • 2.4.4

Solution

Upgrade to versions 2.3.7, 2.4.4 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Learn more about CVSS

Source file

packagist/magento/community-edition/CVE-2022-34259.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:48 +0000.