Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2022-34258

CVE-2022-34258: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

August 16, 2022 (updated November 4, 2022)

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker with admin privileges to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.

References

  • helpx.adobe.com/security/products/magento/apsb22-38.html
  • nvd.nist.gov/vuln/detail/CVE-2022-34258

Code Behaviors & Features

Detect and mitigate CVE-2022-34258 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.3.0 before 2.3.7, all versions starting from 2.4.0 before 2.4.4

Fixed versions

  • 2.3.7
  • 2.4.4

Solution

Upgrade to versions 2.3.7, 2.4.4 or above.

Impact 4.8 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/magento/community-edition/CVE-2022-34258.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:24 +0000.