Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2021-36043

CVE-2021-36043: Magento affected by a blind SSRF vulnerability in the bundled dotmailer extension

May 24, 2022 (updated November 7, 2025)

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by a blind SSRF vulnerability in the bundled dotmailer extension. An attacker with admin privileges could abuse this to achieve remote code execution should Redis be enabled.

References

  • github.com/advisories/GHSA-36xq-7w8w-xp68
  • github.com/magento/magento2
  • helpx.adobe.com/security/products/magento/apsb21-64.html
  • nvd.nist.gov/vuln/detail/CVE-2021-36043

Code Behaviors & Features

Detect and mitigate CVE-2021-36043 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.7-p1, version 2.3.7, all versions starting from 2.4.2-p1 before 2.4.2-p2, version 2.4.2

Fixed versions

  • 2.3.7-p1
  • 2.4.2-p2

Solution

Upgrade to versions 2.3.7-p1, 2.4.2-p2 or above.

Impact 6.6 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-918: Server-Side Request Forgery (SSRF)

Source file

packagist/magento/community-edition/CVE-2021-36043.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:38 +0000.