Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2021-36032

CVE-2021-36032: Magento is affected by an improper input validation vulnerability

May 24, 2022 (updated November 7, 2025)

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability. An authenticated attacker can trigger an insecure direct object reference in the V1/customers/me endpoint to achieve information exposure and privilege escalation.

References

  • github.com/advisories/GHSA-5vw8-r55w-f4q4
  • github.com/magento/magento2
  • helpx.adobe.com/security/products/magento/apsb21-64.html
  • nvd.nist.gov/vuln/detail/CVE-2021-36032

Code Behaviors & Features

Detect and mitigate CVE-2021-36032 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.7-p1, version 2.3.7, all versions starting from 2.4.2-p1 before 2.4.2-p2, version 2.4.2

Fixed versions

  • 2.3.7-p1
  • 2.4.2-p2

Solution

Upgrade to versions 2.3.7-p1, 2.4.2-p2 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation
  • CWE-639: Authorization Bypass Through User-Controlled Key

Source file

packagist/magento/community-edition/CVE-2021-36032.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:06 +0000.