Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2021-36012

CVE-2021-36012: Magento affected by a business logic error in the placeOrder graphql mutation

May 24, 2022 (updated November 6, 2025)

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by a business logic error in the placeOrder graphql mutation. An authenticated attacker can leverage this vulnerability to altar the price of an item.

References

  • github.com/advisories/GHSA-3f97-7pgv-gmgr
  • github.com/magento/magento2
  • helpx.adobe.com/security/products/magento/apsb21-64.html
  • nvd.nist.gov/vuln/detail/CVE-2021-36012

Code Behaviors & Features

Detect and mitigate CVE-2021-36012 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.7-p1, version 2.3.7, all versions starting from 2.4.2-p1 before 2.4.2-p2, version 2.4.2

Fixed versions

  • 2.3.7-p1
  • 2.4.2-p2

Solution

Upgrade to versions 2.3.7-p1, 2.4.2-p2 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Source file

packagist/magento/community-edition/CVE-2021-36012.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:53 +0000.