Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2021-28567

CVE-2021-28567: Magento Improper Authorization vulnerability in the customers module

May 24, 2022 (updated February 10, 2025)

Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are vulnerable to an Improper Authorization vulnerability in the customers module. Successful exploitation could allow a low-privileged user to modify customer data. Access to the admin console is required for successful exploitation.

References

  • github.com/advisories/GHSA-cc3w-r3w8-hfh7
  • github.com/magento/magento2
  • github.com/magento/magento2/commit/1bd5cb8c065e44779526c0b044ce19b884707695
  • helpx.adobe.com/security/products/magento/apsb21-30.html
  • nvd.nist.gov/vuln/detail/CVE-2021-28567

Code Behaviors & Features

Detect and mitigate CVE-2021-28567 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.7, all versions starting from 2.4.0 before 2.4.2-p1

Fixed versions

  • 2.4.2-p1
  • 2.3.7

Solution

Upgrade to versions 2.3.7, 2.4.2-p1 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-285: Improper Authorization
  • CWE-863: Incorrect Authorization

Source file

packagist/magento/community-edition/CVE-2021-28567.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:55 +0000.