Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2021-28556

CVE-2021-28556: Magento DOM-based Cross-Site Scripting vulnerability on mage-messages cookies

May 24, 2022 (updated February 10, 2025)

Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a DOM-based Cross-Site Scripting vulnerability on mage-messages cookies. Successful exploitation could lead to arbitrary JavaScript execution by an unauthenticated attacker. User interaction is required for successful exploitation.

References

  • github.com/advisories/GHSA-39ch-rg26-gmq5
  • github.com/magento/magento2
  • github.com/magento/magento2/commit/1bd5cb8c065e44779526c0b044ce19b884707695
  • helpx.adobe.com/security/products/magento/apsb21-30.html
  • nvd.nist.gov/vuln/detail/CVE-2021-28556

Code Behaviors & Features

Detect and mitigate CVE-2021-28556 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.7, all versions starting from 2.4.0 before 2.4.2-p1

Fixed versions

  • 2.4.2-p1
  • 2.3.7

Solution

Upgrade to versions 2.3.7, 2.4.2-p1 or above.

Impact 4.8 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/magento/community-edition/CVE-2021-28556.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.