Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2020-9689

CVE-2020-9689: Magento path traversal vulnerability

May 24, 2022 (updated February 10, 2025)

Magento versions 2.3.5-p1 and earlier, and 2.3.5-p1 and earlier have a path traversal vulnerability. Successful exploitation could lead to arbitrary code execution.

References

  • github.com/advisories/GHSA-fr6f-xmfx-rrpq
  • github.com/magento/magento2
  • github.com/magento/magento2/commit/9436781734e47c83e96977fa770d255217680d5e
  • helpx.adobe.com/security/products/magento/apsb20-47.html
  • nvd.nist.gov/vuln/detail/CVE-2020-9689

Code Behaviors & Features

Detect and mitigate CVE-2020-9689 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.5-p2

Fixed versions

  • 2.3.5-p2

Solution

Upgrade to version 2.3.5-p2 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Source file

packagist/magento/community-edition/CVE-2020-9689.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:13 +0000.