Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2020-9580

CVE-2020-9580: Magento Security mitigation bypass vulnerability

May 24, 2022 (updated February 10, 2025)

Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a security mitigation bypass vulnerability. Successful exploitation could lead to arbitrary code execution.

References

  • github.com/advisories/GHSA-j2jp-58gv-g2pg
  • github.com/magento/magento2
  • github.com/magento/magento2/commit/52d92dbd07f09620d23693ba0c4d4bdb4ba09916
  • helpx.adobe.com/security/products/magento/apsb20-22.html
  • nvd.nist.gov/vuln/detail/CVE-2020-9580

Code Behaviors & Features

Detect and mitigate CVE-2020-9580 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 2.2.11, all versions starting from 2.3.0 before 2.3.4-p2

Fixed versions

  • 2.3.4-p2

Solution

Upgrade to version 2.3.4-p2 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

packagist/magento/community-edition/CVE-2020-9580.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:12 +0000.