Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2020-9577

CVE-2020-9577: Magento stored cross-site scripting vulnerability

May 24, 2022 (updated February 10, 2025)

Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a stored cross-site scripting vulnerability. Successful exploitation could lead to sensitive information disclosure .

References

  • github.com/advisories/GHSA-689w-2f93-2x67
  • helpx.adobe.com/security/products/magento/apsb20-22.html
  • nvd.nist.gov/vuln/detail/CVE-2020-9577

Code Behaviors & Features

Detect and mitigate CVE-2020-9577 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.4-p2

Fixed versions

  • 2.3.4-p2

Solution

Upgrade to version 2.3.4-p2 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/magento/community-edition/CVE-2020-9577.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.