Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2019-8154

CVE-2019-8154: Improper Input Validation

November 5, 2019 (updated November 12, 2019)

A remote code execution vulnerability exists in Magento. An authenticated user with privileges to modify product catalogs can trigger PHP file inclusion through a crafted XML file that specifies product design update.

References

  • magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
  • nvd.nist.gov/vuln/detail/CVE-2019-8154

Code Behaviors & Features

Detect and mitigate CVE-2019-8154 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.2.0 before 2.2.10, all versions starting from 2.3.0 up to 2.3.2

Fixed versions

  • 2.2.10
  • 2.3.3

Solution

Upgrade to versions 2.2.10, 2.3.3 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-829: Inclusion of Functionality from Untrusted Control Sphere

Source file

packagist/magento/community-edition/CVE-2019-8154.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:11 +0000.