Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2019-8144

CVE-2019-8144: Improper Input Validation

November 5, 2019 (updated November 8, 2019)

A remote code execution vulnerability exists in Magento. An unauthenticated user can insert a malicious payload through PageBuilder template methods.

References

  • magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
  • nvd.nist.gov/vuln/detail/CVE-2019-8144

Code Behaviors & Features

Detect and mitigate CVE-2019-8144 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.3.0 up to 2.3.2

Fixed versions

  • 2.3.3

Solution

Upgrade to version 2.3.3 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

packagist/magento/community-edition/CVE-2019-8144.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:16 +0000.