Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2019-8129

CVE-2019-8129: Magento Cross-Site Scripting via Signifyd Guarantee Option Translation Override

May 24, 2022 (updated May 15, 2024)

A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can exploit it by injecting an embedded expression into a translation.

References

  • github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8129.yaml
  • github.com/advisories/GHSA-wg25-j79r-v5wp
  • github.com/magento/magento2
  • magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
  • nvd.nist.gov/vuln/detail/CVE-2019-8129

Code Behaviors & Features

Detect and mitigate CVE-2019-8129 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.2 before 2.2.10, all versions starting from 2.3 before 2.3.2-p2

Fixed versions

  • 2.2.10
  • 2.3.2-p2

Solution

Upgrade to versions 2.2.10, 2.3.2-p2 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/magento/community-edition/CVE-2019-8129.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:42 +0000.