Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2019-8112

CVE-2019-8112: Insufficient Verification of Data Authenticity

May 24, 2022 (updated July 18, 2023)

A security bypass vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An unauthenticated user can bypass the email confirmation mechanism via GET request that captures relevant account data obtained from the POST response related to new user creation.

References

  • github.com/advisories/GHSA-p9vf-4jx2-5hpp
  • nvd.nist.gov/vuln/detail/CVE-2019-8112
  • web.archive.org/web/20220121051105/https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update

Code Behaviors & Features

Detect and mitigate CVE-2019-8112 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.2 before 2.2.10, all versions starting from 2.3 before 2.3.3

Fixed versions

  • 2.2.10
  • 2.3.3

Solution

Upgrade to versions 2.2.10, 2.3.3 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-345: Insufficient Verification of Data Authenticity

Source file

packagist/magento/community-edition/CVE-2019-8112.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:57 +0000.