Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2019-7928

CVE-2019-7928: Magento 2 Community Edition DoS vulnerability

May 24, 2022 (updated July 17, 2023)

A denial-of-service (DoS) vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. By abusing insufficient brute-forcing defenses in the token exchange protocol, an unauthenticated attacker could disrupt transactions between the Magento merchant and PayPal.

References

  • github.com/advisories/GHSA-hrg3-4q56-p2q5
  • nvd.nist.gov/vuln/detail/CVE-2019-7928
  • web.archive.org/web/20211206084839/https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13

Code Behaviors & Features

Detect and mitigate CVE-2019-7928 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.1 before 2.1.18, all versions starting from 2.2 before 2.2.9, all versions starting from 2.3 before 2.3.2

Fixed versions

  • 2.1.18
  • 2.2.9
  • 2.3.2

Solution

Upgrade to versions 2.1.18, 2.2.9, 2.3.2 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Source file

packagist/magento/community-edition/CVE-2019-7928.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:59 +0000.