Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2019-7897

CVE-2019-7897: Cross-site Scripting

August 2, 2019 (updated August 8, 2019)

A stored cross-site scripting vulnerability exists in the admin panel of Magento. This could be exploited by an authenticated user with privileges to customer configurations to inject malicious javascript.

References

  • magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13
  • nvd.nist.gov/vuln/detail/CVE-2019-7897

Code Behaviors & Features

Detect and mitigate CVE-2019-7897 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.9.4.2, all versions starting from 2.1.0 before 2.1.18, all versions starting from 2.2.0 before 2.2.9, all versions starting from 2.3.0 before 2.3.2

Fixed versions

  • 1.9.4.2
  • 2.1.18
  • 2.2.9
  • 2.3.2

Solution

Upgrade to versions 1.9.4.2, 2.1.18, 2.2.9, 2.3.2 or above.

Impact 4.8 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/magento/community-edition/CVE-2019-7897.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.