Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. magento/community-edition
  4. ›
  5. CVE-2019-7896

CVE-2019-7896: Improper Input Validation

August 2, 2019 (updated August 7, 2019)

A remote code execution vulnerability exists in Magento. An authenticated user with administrator privileges to layouts can execute arbitrary code through a combination of product import, crafted csv file and XML layout update.

References

  • magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13
  • nvd.nist.gov/vuln/detail/CVE-2019-7896

Code Behaviors & Features

Detect and mitigate CVE-2019-7896 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.1.0 before 2.1.18, all versions starting from 2.2.0 before 2.2.9, all versions starting from 2.3.0 before 2.3.2

Fixed versions

  • 2.1.18
  • 2.2.9
  • 2.3.2

Solution

Upgrade to versions 2.1.18, 2.2.9, 2.3.2 or above.

Impact 7.2 HIGH

CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

packagist/magento/community-edition/CVE-2019-7896.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:10 +0000.