Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. librenms
  4. ›
  5. CVE-2022-36746

CVE-2022-36746: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

August 31, 2022 (updated September 16, 2022)

LibreNMS v22.6.0 was discovered to contain a cross-site scripting (XSS) vulnerability via the component oxidized-cfg-check.inc.php.

References

  • github.com/advisories/GHSA-325v-g5vx-whxc
  • github.com/librenms/librenms/pull/14126
  • nvd.nist.gov/vuln/detail/CVE-2022-36746

Code Behaviors & Features

Detect and mitigate CVE-2022-36746 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 22.6.0

Fixed versions

  • 22.6.0

Solution

Upgrade to version 22.6.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/librenms/CVE-2022-36746.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:13 +0000.