Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. joomla/joomla-cms
  4. ›
  5. CVE-2011-2509

CVE-2011-2509: Joomla! vulnerable to Cross-site Scripting

May 14, 2022 (updated October 31, 2025)

Multiple cross-site scripting (XSS) vulnerabilities in Joomla! before 1.6.4 allow remote attackers to inject arbitrary web script or HTML via (1) the query string to the com_contact component, as demonstrated by the Itemid parameter to index.php; (2) the query string to the com_content component, as demonstrated by the filter_order parameter to index.php; (3) the query string to the com_newsfeeds component, as demonstrated by an arbitrary parameter to index.php; or (4) the option parameter in a reset.request action to index.php; and, when Internet Explorer or Konqueror is used, (5) allow remote attackers to inject arbitrary web script or HTML via the searchword parameter in a search action to index.php in the com_search component.

References

  • github.com/advisories/GHSA-vcq7-x4wr-w2mj
  • nvd.nist.gov/vuln/detail/CVE-2011-2509

Code Behaviors & Features

Detect and mitigate CVE-2011-2509 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.6.4

Fixed versions

  • 1.6.4

Solution

Upgrade to version 1.6.4 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/joomla/joomla-cms/CVE-2011-2509.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:10 +0000.