Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. joomla/filter
  4. ›
  5. CVE-2022-23800

CVE-2022-23800: Cross-site Scripting (XSS) within joomla/filter class

March 31, 2022 (updated May 15, 2024)

An issue was discovered in Joomla! 4.0.0 through 4.1.0. Inadequate content filtering leads to XSS vulnerabilities in various components.

References

  • developer.joomla.org/security-centre/877-20220308-core-inadequate-content-filtering-within-the-filter-code.html
  • github.com/FriendsOfPHP/security-advisories/blob/master/joomla/filter/CVE-2022-23800.yaml
  • github.com/advisories/GHSA-qcv6-h33g-hvrc
  • github.com/joomla-framework/filter
  • nvd.nist.gov/vuln/detail/CVE-2022-23800

Code Behaviors & Features

Detect and mitigate CVE-2022-23800 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.4.4, all versions starting from 2.0.0 before 2.0.1

Fixed versions

  • 1.4.4
  • 2.0.1

Solution

Upgrade to versions 1.4.4, 2.0.1 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/joomla/filter/CVE-2022-23800.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:09 +0000.