Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. guzzlehttp/oauth-subscriber
  4. ›
  5. CVE-2025-21617

CVE-2025-21617: Guzzle OAuth Subscriber has insufficient nonce entropy

January 6, 2025 (updated July 15, 2026)

Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source (https://github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php#L192). This can leave servers vulnerable to replay attacks when TLS is not used.

References

  • github.com/FriendsOfPHP/security-advisories/blob/master/guzzlehttp/oauth-subscriber/CVE-2025-21617.yaml
  • github.com/advisories/GHSA-237r-r8m4-4q88
  • github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php
  • github.com/guzzle/oauth-subscriber/commit/92b619b03bd21396e51c62e6bce83467d2ce8f53
  • github.com/guzzle/oauth-subscriber/releases/tag/0.8.1
  • github.com/guzzle/oauth-subscriber/security/advisories/GHSA-237r-r8m4-4q88
  • nvd.nist.gov/vuln/detail/CVE-2025-21617

Code Behaviors & Features

Detect and mitigate CVE-2025-21617 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.8.1

Fixed versions

  • 0.8.1

Solution

Upgrade to version 0.8.1 or above.

Impact 3.7 LOW

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-338: Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)

Source file

packagist/guzzlehttp/oauth-subscriber/CVE-2025-21617.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:41 +0000.