Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. grumpydictator/firefly-iii
  4. ›
  5. CVE-2020-27981

CVE-2020-27981: Cross-site Scripting

October 28, 2020 (updated November 3, 2020)

An XSS vulnerability in the auto-complete function of the description field (for new or edited transactions) in Firefly III allows the user to execute JavaScript via suggested transaction titles. NOTE: this is exploitable only in a non-default configuration where Content Security Policy headers are disabled.

References

  • github.com/firefly-iii/firefly-iii/issues/3990
  • nvd.nist.gov/vuln/detail/CVE-2020-27981

Code Behaviors & Features

Detect and mitigate CVE-2020-27981 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.4.5

Fixed versions

  • 5.4.5

Solution

Upgrade to version 5.4.5 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Source file

packagist/grumpydictator/firefly-iii/CVE-2020-27981.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:24 +0000.