Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. grumpydictator/firefly-iii
  4. ›
  5. CVE-2019-13645

CVE-2019-13645: Cross-site Scripting

July 18, 2019

Firefly III is vulnerable to stored XSS due to lack of filtration of user-supplied data in image file names. The JavaScript code is executed during attachments/edit/$file_id$ attachment editing.

References

  • nvd.nist.gov/vuln/detail/CVE-2019-13645

Code Behaviors & Features

Detect and mitigate CVE-2019-13645 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.7.17.3

Fixed versions

  • 4.7.17.3

Solution

Upgrade to version 4.7.17.3 or above.

Impact 5.4 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/grumpydictator/firefly-iii/CVE-2019-13645.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:08 +0000.