Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. gp247/core
  4. ›
  5. CVE-2025-57407

CVE-2025-57407: GP247 and S-Cart have a stored cross-site scripting (XSS) vulnerability

September 23, 2025 (updated November 10, 2025)

A stored cross-site scripting (XSS) vulnerability in the Admin Log Viewer of S-Cart <=10.0.3 allows a remote authenticated attacker to inject arbitrary web script or HTML via a crafted User-Agent header. The script is executed in an administrator’s browser when they view the security log page, which could lead to session hijacking or other malicious actions.

References

  • github.com/advisories/GHSA-46v4-5mc8-q2cf
  • github.com/gp247net/core/commit/e9848706b41d835ca3d668cb1554650403e86da1
  • github.com/gp247net/core/releases/tag/1.1.24
  • github.com/s-cart/core/blob/7c9aa42761be5fd0131c61dbe2b5323beb96d5dd/src/Admin/Controllers/AdminLogController.php
  • nvd.nist.gov/vuln/detail/CVE-2025-57407

Code Behaviors & Features

Detect and mitigate CVE-2025-57407 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.1.24

Fixed versions

  • 1.1.24

Solution

Upgrade to version 1.1.24 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/gp247/core/CVE-2025-57407.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:37 +0000.