Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. globalpayments/php-sdk
  4. ›
  5. CVE-2019-20455

CVE-2019-20455: Improper Certificate Validation

October 12, 2021 (updated November 18, 2021)

Gateways/Gateway.php in Heartland & Global Payments PHP SDK before 2.0.0 does not enforce SSL certificate validations.

References

  • github.com/advisories/GHSA-pm77-c4q7-3fwj
  • github.com/globalpayments/php-sdk/compare/1.3.3...2.0.0
  • github.com/globalpayments/php-sdk/pull/8
  • github.com/globalpayments/php-sdk/pull/8/commits/c86e18f28c5eba0d6ede7d557756d978ea83d3c9
  • github.com/globalpayments/php-sdk/releases/tag/2.0.0
  • nvd.nist.gov/vuln/detail/CVE-2019-20455
  • winterdragon.ca/global-payments-vulnerability/

Code Behaviors & Features

Detect and mitigate CVE-2019-20455 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.0.0

Fixed versions

  • 2.0.0

Solution

Upgrade to version 2.0.0 or above.

Impact 5.9 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-295: Improper Certificate Validation

Source file

packagist/globalpayments/php-sdk/CVE-2019-20455.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:57 +0000.