Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. genix/cms
  4. ›
  5. CVE-2017-14231

CVE-2017-14231: Improper Input Validation

September 10, 2017 (updated September 19, 2017)

GeniXCMS allows remote attackers to cause a denial of service (account blockage) by leveraging the mishandling of certain username substring relationships, such as the admin<script> username versus the admin username, related to register.php, User.class.php, and Type.class.php.

References

  • nvd.nist.gov/vuln/detail/CVE-2017-14231

Code Behaviors & Features

Detect and mitigate CVE-2017-14231 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.0.2

Fixed versions

  • 1.1.0

Solution

Upgrade to version 1.1.0 or above.

Impact 5.3 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

packagist/genix/cms/CVE-2017-14231.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:15 +0000.