Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. flarum/core
  4. ›
  5. GHSA-xjvc-pw2r-6878

GHSA-xjvc-pw2r-6878: Flarum: Path traversal in LESS parser via theme color settings (incomplete fix for CVE-2023-27577)

April 22, 2026

Flarum’s patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the custom_less setting, but the same restriction was never applied to other settings registered as LESS config variables (for example theme_primary_color and theme_secondary_color, as well as any key registered via Extend\Settings::registerLessConfigVar()).

Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '<path>', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery).

References

  • github.com/advisories/GHSA-xjvc-pw2r-6878
  • github.com/flarum/framework
  • github.com/flarum/framework/commit/2d90a1f19f0e46f8c7e1b07c48ba74b5e38f8410
  • github.com/flarum/framework/releases/tag/v1.8.16
  • github.com/flarum/framework/releases/tag/v2.0.0-rc.1
  • github.com/flarum/framework/security/advisories/GHSA-vhm8-wwrf-3gcw
  • github.com/flarum/framework/security/advisories/GHSA-xjvc-pw2r-6878
  • nvd.nist.gov/vuln/detail/CVE-2023-27577

Code Behaviors & Features

Detect and mitigate GHSA-xjvc-pw2r-6878 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.8.16, all versions starting from 2.0.0-beta.1 before 2.0.0-rc.1

Fixed versions

  • 1.8.16
  • 2.0.0-rc.1

Solution

Upgrade to versions 1.8.16, 2.0.0-rc.1 or above.

Impact 4.9 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
  • CWE-918: Server-Side Request Forgery (SSRF)

Source file

packagist/flarum/core/GHSA-xjvc-pw2r-6878.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:49 +0000.