Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. elefant/cms
  4. ›
  5. CVE-2018-16975

CVE-2018-16975: Improper Input Validation

September 12, 2018 (updated November 19, 2018)

An issue was discovered in Elefant CMS There is a PHP Code Execution Vulnerability in /designer/add/stylesheet.php by using a .php extension in the New Stylesheet Name field in conjunction with <?php content, because of insufficient input validation in apps/designer/handlers/csspreview.php.

References

  • nvd.nist.gov/vuln/detail/CVE-2018-16975

Code Behaviors & Features

Detect and mitigate CVE-2018-16975 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.0.7

Fixed versions

  • 2.0.7

Solution

Upgrade to version 2.0.7 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

packagist/elefant/cms/CVE-2018-16975.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:14 +0000.