Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/tfa
  4. ›
  5. CVE-2025-31694

CVE-2025-31694: Drupal Two-factor Authentication (TFA) Vulnerable to Forceful Browsing

April 1, 2025 (updated April 29, 2025)

Incorrect Authorization vulnerability in Drupal Two-factor Authentication (TFA) allows Forceful Browsing. This issue affects Two-factor Authentication (TFA): from 0.0.0 before 1.10.0.

References

  • git.drupalcode.org/project/tfa
  • github.com/advisories/GHSA-hf6c-fgp3-jfch
  • nvd.nist.gov/vuln/detail/CVE-2025-31694
  • www.drupal.org/sa-contrib-2025-023

Code Behaviors & Features

Detect and mitigate CVE-2025-31694 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.10.0

Fixed versions

  • 1.10.0

Solution

Upgrade to version 1.10.0 or above.

Impact 8.1 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-288: Authentication Bypass Using an Alternate Path or Channel
  • CWE-863: Incorrect Authorization

Source file

packagist/drupal/tfa/CVE-2025-31694.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:55 +0000.