Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/simple_multistep
  4. ›
  5. CVE-2025-12761

CVE-2025-12761: Drupal Simple multi step form allows Cross-Site Scripting

November 18, 2025 (updated November 19, 2025)

Improper Neutralization of Input During Web Page Generation (“Cross-site Scripting”) vulnerability in Drupal Simple multi step form allows Cross-Site Scripting (XSS).This issue affects Simple multi step form: from 0.0.0 before 2.0.0.

References

  • git.drupalcode.org/project/simple_multistep
  • github.com/advisories/GHSA-gg35-374m-9ph8
  • nvd.nist.gov/vuln/detail/CVE-2025-12761
  • www.drupal.org/sa-contrib-2025-116

Code Behaviors & Features

Detect and mitigate CVE-2025-12761 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.0.0

Fixed versions

  • 2.0.0

Solution

Upgrade to version 2.0.0 or above.

Impact 3.5 LOW

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/drupal/simple_multistep/CVE-2025-12761.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:33 +0000.