Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/link_field_display_mode_formatter
  4. ›
  5. CVE-2025-31695

CVE-2025-31695: Drupal Link field display mode formatter Cross-Site Scripting (XSS) vulnerability

April 1, 2025 (updated April 29, 2025)

Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’) vulnerability in Drupal Link field display mode formatter allows Cross-Site Scripting (XSS). This issue affects Link field display mode formatter: from 0.0.0 before 1.6.0.

References

  • git.drupalcode.org/project/link_field_display_mode_formatter
  • github.com/advisories/GHSA-p2wg-8h29-874v
  • nvd.nist.gov/vuln/detail/CVE-2025-31695
  • www.drupal.org/sa-contrib-2025-024

Code Behaviors & Features

Detect and mitigate CVE-2025-31695 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.6.0

Fixed versions

  • 1.6.0

Solution

Upgrade to version 1.6.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/drupal/link_field_display_mode_formatter/CVE-2025-31695.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:49 +0000.